快捷搜索: 长连接 前端 源码 pan

npm install element-ui -S 报错

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: admin@0.1.0
npm ERR! Found: vue@3.2.31
npm ERR! node_modules/vue
npm ERR!   vue@"^3.2.13" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer vue@"^2.5.17" from element-ui@2.15.6
npm ERR! node_modules/element-ui
npm ERR!   element-ui@"*" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

出现此类问题是因为你的Vue版本和element版本不匹配,不要盲目的运行命令,如果使用的是Vue3一定要安装element-plus插件

运行命令为:

npm install element-plus --save

如果强制安装 element-ui 执行类似命令 npm i element-ui -S -–legacy-peer-deps或者npm install element-plus --save,在后续的项目中可能还是会出现错误。

经验分享 程序员 微信小程序 职场和发展